QuoteSeek - free to use insurance comparison site

Isuzu Trooper Owners Club UKô
Isuzu Trooper, Rodeo, Bighorn, Mu & VehiCROSS Owners Club
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
CalendarCalendar  ITOCUK Club ShopClub Shop  ITOCUK Classified Ads serviceClassified Ads
ITOCUK HomeITOCUK Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

ELEC .IG Fuse - What does it do?

Goto page Previous  1, 2
 
Post new topic   Reply to topic    Isuzu Trooper Owners Club UKô Forum Index -> Electrics / wiring / lights etc
View previous topic :: View next topic  
Author Message
EdTBroom
***


Joined: 27 Jul 2009
Posts: 239
Location: Sheffield

PostPosted: Sat May 05, 2018 8:52    Post subject: Reply with quote

Looking for reason my PowerWindows are not working

As usual Forum has the answer Laughing  Laughing  Windows good now  Very Happy

It seems  the guy who solved problemeight years ago was me   Rolling Eyes  Embarassed

Weird or am I just going senile  Question
:
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Sat May 05, 2018 8:52    Post subject: Google Ads keep this community free to join!


Back to top
Mahorn
*


Joined: 21 Sep 2020
Posts: 13
Location: Reading

PostPosted: Mon Sep 21, 2020 20:27    Post subject: power windows stopped working/ Reply with quote

I think I have a similar problem. On the dash I have both ABS and 4wd lights on steady. Tried replacing power windows relay in the middle and 10 amp fuse but as I switch off and on again the engine the C4 10 amp fuse has gone stopping electric windows again.
Abs light disappears when I change fuse for a good 5 minutes then on again when fuse has blown. Power windows also work until I switch on the engine again.
4wd light should be linked to C4 according to diagram on repair/service manual but did not disappear when I replaced fuses. I am at loss.
I can't remember if the blower and a/c was on when I tried. could the blue relay in the engine fusebox be the cause?
Back to top
View user's profile Send personal message
Mahorn
*


Joined: 21 Sep 2020
Posts: 13
Location: Reading

PostPosted: Tue Nov 03, 2020 22:40    Post subject: Re: power windows stopped working/ Reply with quote

Mahorn wrote:
I think I have a similar problem. On the dash I have both ABS and 4wd lights on steady. Tried replacing power windows relay in the middle and 10 amp fuse but as I switch off and on again the engine the C4 10 amp fuse has gone stopping electric windows again.
Abs light disappears when I change fuse for a good 5 minutes then on again when fuse has blown. Power windows also work until I switch on the engine again.
4wd light should be linked to C4 according to diagram on repair/service manual but did not disappear when I replaced fuses. I am at loss.
I can't remember if the blower and a/c was on when I tried. could the blue relay in the engine fusebox be the cause?


I reply to myself just to give an update. As soon as I replaced the car stereo with a new one, I wanted to see if that old stereo was also making the whole circuit instable therefore I also replaced the blown C4 10 amp fuse with a new one. So far so good. ABS light is off, fuse has not blown in a week. Usually it was gone by 1-4 minutes. Green 4wd light is still on the dash but in the meantime I discovered that the vacuum solenoid is disconnected due to perished hoses, therefore the vacuum piping circuit is open now. I read this may affect the 4wd operation. I have ordered new pipes and waiting to replace the missing ones. I wish I had a vacuum piping diagram at hand as the swirl vacuum valve has 2 nozzles and I don't know which pipe goes where. Apparently there is also a "T" and a missing inline filter, which I am going to  replace but I have no clue on where to locate it. Mine is a 1996 Vauxhall monterey 3.1td.
Back to top
View user's profile Send personal message
Mahorn
*


Joined: 21 Sep 2020
Posts: 13
Location: Reading

PostPosted: Mon Jul 19, 2021 16:48    Post subject: Reply with quote

OccasionalLurker wrote:
Right, problem solved then, with the help of that workshop manual, thanks very much everybody.

It was a duff power-window relay - which is not immediately obvious on the 3.1 as it's actually behind the fusebox so that you have to get your head into the footwell to see it.
I'm hypothesising that the relay's internals had burnt out and there was consequently a fairly big short that blew the 10A C4 fuse. I removed the relay, put in a weaker fuse in the C4 slot and the ABS and rear demister worked fine. Replacing the duff relay with a good one made the windows work fine too.

Who knows it might make 250,000 miles yet. Very Happy

Thanks again for the assistance and suggestions.


Is it possible to get a picture uploaded of the aforementioned duff power window relay. Still at square one on this. Mine is a 1996 isuzu trooper...I understand this is a very old thread but you never know.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Isuzu Trooper Owners Club UKô Forum Index -> Electrics / wiring / lights etc All times are GMT + 1 Hour
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group