4x4 & MPV Driver - 40% subscription discount

Isuzu Trooper Owners Club UKô
Isuzu Trooper, Rodeo, Bighorn, Mu & VehiCROSS Owners Club
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
CalendarCalendar  ITOCUK Club ShopClub Shop  ITOCUK Classified Ads serviceClassified Ads
ITOCUK HomeITOCUK Home   dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs

3.1 Engine does not run above 1600rpm


 
Post new topic   Reply to topic    Isuzu Trooper Owners Club UKô Forum Index -> Engines
View previous topic :: View next topic  
Author Message
Conrad777
Newbie


Joined: 09 Nov 2021
Posts: 1
Location: Belize

PostPosted: Fri Jan 14, 2022 20:25    Post subject: 3.1 Engine does not run above 1600rpm Reply with quote

Help.I own a  1996 Opel Monterey 3.1 d in real good nick.Around 150.000 km.Some time ago the engine stalled,came on again,and them settled for around 1600 rpm.It happened near home,and I managed to limp back.At home I changed fuelfilter,quite dirty,cleaned the tank,no significant dirt/water came out.Engine however didn't run above 1600 rpm .Then I tried to feed the injection pump by gravity and even by electric pump.No improvement!!
Since I am in Belize where someone with a bahco a hammer and a chissle,who can make a 4 cylinder run on 2 cylinder,is considered an excellent mechanica,I am affraid to call in a local specialist,seen to many vehicles with half of their engine in the lugage compartment.Who can help me out of this predicament?
Rest me to say that ever so often I have mixed the local third world diesel with filtered cooking oil.This without ever experiencing adverse effects.My injection pump is a Bosch with bowden cable.
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Fri Jan 14, 2022 20:25    Post subject: Google Ads keep this community free to join!


Back to top
Versatile
*


Joined: 19 Aug 2015
Posts: 44
Location: Worcestershire

PostPosted: Mon Jan 17, 2022 21:34    Post subject: Reply with quote

Hi. It certainly sounds like a fuel and/or an air problem. When ever my engine starts to loose revs it's usually the filter blocking up with the not so filtered chip oil. It does come back though. I've run it until the engine stalls but it will start again and as long as I don't rev it then it will get me home. Then I change the filter and make sure the line is cleaned out too with HP air. That usually does the trick.
I haven't had a HP fuel pump fail on me but I do know the glycerine in the oil can make the pump seals go hard so I mix my oil with road diesel to help it out.

What about the air filter? Have you tried running it without one just to see if it will rev ?

This place is fairly quiet now most of the others have gone over to facebook. You might want to try looking there for more ( better ) advice.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Isuzu Trooper Owners Club UKô Forum Index -> Engines All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group